windows compile error

Joanna Chopard (jchopard) jchopard at
Thu Aug 30 11:52:09 EDT 2007

Actually, now that I know the problem, I tried stopping the make just
after it generated Account.c and copied a back up of it.  After that,
the make went through fine.
But thanks for the pointers!!!


-----Original Message-----
From: devel-bounces at [mailto:devel-bounces at] On Behalf
Of Joanna Chopard (jchopard)
Sent: Thursday, August 30, 2007 5:45 PM
To: Daniel Atallah
Cc: devel at
Subject: RE: windows compile error

Thanks for the suggestion.
You are right about Account.c.  It's somehow empty!

However, I just tried make clean and still no luck.
I still get the same error:(


-----Original Message-----
From: Daniel Atallah [mailto:daniel.atallah at]
Sent: Thursday, August 30, 2007 5:38 PM
To: Joanna Chopard (jchopard)
Cc: devel at
Subject: Re: windows compile error

On 8/30/07, Joanna Chopard (jchopard) <jchopard at> wrote:
> I followed the instructions on 'Pidgin for Windows Build Instructions'
> I get the following error for
> libpurple/plugins/perl/common/ and not sure what to do next.  I'm 
> afraid I don't really know .xs file format.
> ===============================================================
> gcc.exe -shared Account.o AccountOpts.o BuddyIcon.o BuddyList.o 
> Cipher.o Cmds.o Connection.o Conversation.o Core.o Debug.o FT.o 
> Purple.o ImgStore.o Log.o Networ k.o Notify.o Plugin.o PluginPref.o 
> Pounce.o Prefs.o Privacy.o Proxy.o Prpl.o Req uest.o Roomlist.o 
> SSLConn.o SavedStatuses.o Signal.o Server.o Sound.o Status.o S 
> tringref.o Util.o XMLNode.o
> -L../../../../../win32-dev/perl58 -L.. -L../../../..
> /libpurple -L../../../../../win32-dev/gtk_2_0/lib -lperl58 -lperl 
> -lpurple -lgli b-2.0 -o Purple.dll
> Purple.o: In function
> `boot_Purple':c:/dev/pidgin_dev/pidgin-2.1.1/libpurple/plu
> gins/perl/common/Purple.xs:43: undefined reference to
> unde
> fined reference to `boot_Purple__Account__Option'
> collect2: ld returned 1 exit status
> make: *** [Purple.dll] Error 1
> ===============================================================

This is a weird issue that I've seen happen once or twice before.  For
some reason, the AccountOpts.c generation overwrites the previously
generated Account.c.  If you `make -f Makefile.mingw clean` in the
"purple/plugins/perl/common" directory and then `make -f Makefile.mingw`
in that directory again, it should work.


Devel mailing list
Devel at

More information about the Devel mailing list