HTTP proxy does not work for pidgin 2.0 but native AIM client is ok

George YE gye_test at
Thu Jun 14 13:40:03 EDT 2007

I tried the port 443 but got window socket error #10054.
Tracing the network traffic using ethereal found that native aim client is able to try the url first, from which the client seems render a session id, which is used for all later http request.

Reading the code of libpurble/proxy.c, looks the pidgin client is trying to ask the http proxy to setup a connection for it to aim and relay traffic back and forth using this connection. Looks a lot of http proxy does not honor this kind of tunneling.


----- Original Message ----
From: Mark Doliner <mark at>
To: George YE <gye_test at>; devel at
Sent: Wednesday, June 13, 2007 11:36:00 PM
Subject: Re: HTTP proxy does not work for pidgin 2.0 but native AIM client is ok

On Wed, 13 Jun 2007 23:16:16 -0700 (PDT), George YE wrote
> Hi,
> I found an interesting problem while using pidgin 2.0. I was trying 
> to use a http proxy to try to connect with my aim account. The 
> pidgin client failed due to the proxy does not support http 
> tunneling. But native aim client works fine with the same proxy 
> setting.  Any idea why pidgin try to do http tunneling instead of 
> pure http proxy relay.
> Thanks,
> gye

Have you tried setting your AIM account to connect to on
port 443 instead of port 5190?  It's on the Advanced tab when editing your


Fussy? Opinionated? Impossible to please? Perfect.  Join Yahoo!'s user panel and lay it on us. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list