About ProgressReport and msn-pecan

Sean Egan seanegan at gmail.com
Thu Jun 12 18:18:21 EDT 2008

2008/6/12 John Bailey <rekkanoryo at rekkanoryo.org>:
> We don't all insist on supporting the "stone age," so to speak, but even those
> of us that support forgetting about the older library versions realize that it
> will break things for some people.  We have debated the compatibility thing on
> more than one occasion, and we did finally come to a consensus to require glib
> 2.4.0 (I think, but it might have been 2.6.0) for 3.0.0.

I think Warren Togami, from RedHat, has been the biggest influence in
us keeping our GTK+ dependencies modest. The reasoning is that Pidgin
is in a unique class of software that can break at a moment's notice
by no fault of its own (as has happened before). When this happens, a
distro has to do an upgrade to all the releases it currently supports,
which may be many years old. If a protocol breaks, or has a security
issue, it's probably easier to just upgrade to the latest version of
Pidgin than it is to cherry-pick the fixes to every released version
that happens to be in a distro. Since it's not plausible for a distro
to upgrade a major library just to fix a Pidgin bug, and the Pidgin
developers are really the only ones seriously affected by the
restriction, it makes most sense just not to depend on anything too

More information about the Devel mailing list