Access is Denied

Daniel Atallah daniel.atallah at
Thu Aug 12 09:29:05 EDT 2010

On Thu, Aug 12, 2010 at 09:18, Jim Menkevich <jim.menkevich at> wrote:
> In the .bashrc file, there is a line that says this...
> unset TMP
> unset TEMP
> I commented these and these variables are now set, however, I'm still
> getting the same error.
> I also did a make clean and tried again and no luck.

I can't think of anything else offhand that I know of which would cause this.

You can try to see what is actually failing by using ProcessMonitor

You'll probably need to seek support from the mingw folks if that
doesn't reveal the source of the problem.


> On Thu, Aug 12, 2010 at 9:06 AM, Daniel Atallah <daniel.atallah at>
> wrote:
>> On Thu, Aug 12, 2010 at 08:54, Jim Menkevich <jim.menkevich at>
>> wrote:
>> > $ windres --version
>> > GNU windres (GNU Binutils) 2.20
>> Ok, that's the same version that I have, so it shouldn't be a problem.
>> > I checked the permissions to TMP and TEMP (which point to the same
>> > location):
>> > %USERPROFILE%\AppData\Local\Temp
>> > And I had all permissions to that directory.
>> > However, when I echo'ed these in Cygwin, they came back as empty.  Do I
>> > have
>> > to set these up in my .bashrc file?
>> Hmm... by default I thought that cygwin exported these.
>> If you define $TMP and/or $TEMP to an appropriate value, I think that
>> should solve your problems.
>> -D

More information about the Devel mailing list