Pidgin and buildbot

Phil Hannent phil at
Mon Feb 1 11:31:59 EST 2010


I used to run a buildbot of Pidgin so that I could test branches.  Late
last year it broke because of a change to the build process.

It worked fine in cygwin's bash shell but failed to build in buildbot.

I have only just gotten around to having a look at fixing the issue.  I
was hoping that I could get around it via commands to buildbot however I
am at an impasse right now.

My problem is that buildbot does not appear to like to run in bash mode
so I lose the ability to use unix file paths which breaks this:

awk 'BEGIN {FS="[\\(\\)\\[\\]]"} \
    /^m4_define..purple_major_version/ {system("sed -e
s/@PURPLE_MAJOR_VERSION@/"$5"/ ../libpurple/ >
../libpurple/version.h");} \
    /^m4_define..purple_minor_version/ {system("sed -e
s/@PURPLE_MINOR_VERSION@/"$5"/ ../libpurple/version.h >
../libpurple/version.h.tmp && mv ../libpurple/version.h.tmp
../libpurple/version.h");} \
    /^m4_define..purple_micro_version/ {system("sed -e
s/@PURPLE_MICRO_VERSION@/"$5"/ ../libpurple/version.h >
../libpurple/version.h.tmp && mv ../libpurple/version.h.tmp
../libpurple/version.h"); exit}' ../

The ../libpurple/ means that the version.h is not updated and the
compile fails somewhere in the plugin.c file for obvious reasons.

I tried getting buildbot to run bash with the build commands in a script
file but it had not affect.

Is there a way of not having the ../libpurple/ since that is the current
context anyway?

Phil Hannent

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 259 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the Devel mailing list