Re-namespacing Pidgin's API for Introspection
a at nevitus.org
Fri Feb 7 15:18:17 EST 2014
> I am not sure I have understood the issue but AFAIK we have different
> * Pidgin
> * Purple
> * Gnt
> * Finch
> each of them refering to the specific component.
> The Gtk namespace is used most of the times when we write a gtkwidget which
> is not shipped by Gtk+ so we maintain it locally (gtkimhtml, as example)
> The problem is to have this Gtk and Pidgin namespace together? I don't think
> they should be merged since one is referring to gtk widgets and the other
> one is Pidgin's API.
The way introspection expects it is that everything from libpurple goes
into the Purple namespace, everything from libgnt into Gnt, pidgin into
Pidgin and finch into Finch (which I also personally believe is the right
way), without defining things in the Gtk or Glib namespaces. This would
allow, for instance, a python plugin to do
'from gi.repository import Pidgin' and use Pidgin.Whatever stuff.
The distinction you are suggesting can be handled by something like
PidginGtkWebView instead of GtkWebView, if really needed. Still,
PidginWebView still sounds cleaner. The generated gtk-doc docs will show a
type heirarchy for GObjects, widgets etc.
Moreover, I don't think it makes sense that things being gtk widgets
should belong to the gtk namespace regardless of them not being a part of
gtk. It sounds like renaming PurpleAccount into GAccount or something
after making it a GObject is necessary (stupid comparision, I know).
More information about the Devel