<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv="Content-Type" content="text/html; charset=iso-8859-2">
<META name="GENERATOR" content="onet.poczta">
<STYLE TYPE="text/css"><!--P {margin:0px}--></STYLE>
</HEAD><BODY>
<P>I wrote code like in example but it wont work, why ?<BR>Here is the code:<BR><BR>&nbsp;init_libpurple();<BR>&nbsp;PurplePlugin *pp = purple_plugin_probe("libicq.dll");<BR>&nbsp;if ( !pp ) {<BR>&nbsp;&nbsp;MessageBox( 0, "Nie można załadować wtyczki", NAZWAPROGRAMU, 0 );<BR>&nbsp;&nbsp;return 0;<BR>&nbsp;}<BR>&nbsp;purple_plugin_load(pp);<BR>&nbsp;purple_plugin_register(pp);<BR>&nbsp;PurpleAccount *pa = purple_account_new( "Gizmo", pp-&gt;info-&gt;id );<BR>&nbsp;if ( !pa ) {<BR>&nbsp;&nbsp;MessageBox( 0, "Nie można utworzyć konta", NAZWAPROGRAMU, 0 );<BR>&nbsp;&nbsp;return 0;<BR>&nbsp;}<BR>&nbsp;purple_account_set_username( pa, "467883116" );<BR>&nbsp;purple_account_set_password ( pa, "password" );<BR>&nbsp;purple_account_set_enabled( pa, UI_ID, TRUE );<BR>&nbsp;purple_account_connect( pa );<BR>&nbsp;PurpleConnection *pc = purple_account_get_connection( pa );<BR>&nbsp;if ( pc ) {<BR>&nbsp;&nbsp;purple_connection_set_account( pc, pa );<BR>&nbsp;&nbsp;pc-&gt;prpl = pp;<BR>&nbsp;}<BR>&nbsp;PurpleSavedStatus *status = purple_savedstatus_new(NULL, PURPLE_STATUS_AVAILABLE);<BR>&nbsp;purple_savedstatus_activate(status);<BR>&nbsp;connect_to_signals_for_demonstration_purposes_only();<BR><BR>What am i doing wrong ?</P></BODY></HTML>