XMPP Rejecting PLAIN, "No worthy mechs found" Red Hat 5.5

Paul Aurich darkrain42 at pidgin.im
Wed Sep 8 21:57:21 EDT 2010

On 2010-09-08 12:05, Alan De Smet wrote:
> I'm using Pidgin as shipped with Red Hat 5.5.  Pidgin identifies as 
> "Pidgin 2.6.6-2.el5_4".

The Help->About information is usually going to be more helpful (it
catches situations in which there's a locally-installed
pidgin/libpurple), but I don't think that's the issue.

> I've tried stracing Pidgin to see if there were other files in my 
> home directory that it might be reading and receiving bad
> information from; I didn't find any.  I do not have a ~/.pidgin or
> ~/.gaim.  I nosed around in gconf-editor for a bit and didn't find
> anything that seemed relevant to Pidgin.

Pidgin's configuration is in ~/.purple, with the optional ability to
have a distro pre-seed prefs.xml someplace in /etc/, but that's not
going to be the issue here.

> jabber: Recv (ssl)(129): <stream:features><mechanisms xmlns='urn:ietf:params:xml:ns:xmpp-sasl'><mechanism>PLAIN</mechanism></mechanisms></stream:features>
> sasl: Mechs found: PLAIN 
> sasl: No worthy mechs found
> jabber: Sending (ssl) (DELETED at wisc.edu/Work): <iq type='get' id='purple48d8c222'><query xmlns='jabber:iq:auth'><username>DELETED</username></query></iq>

> The "No worthy mechs found" seems suspicious.  Comparing to a
> co-worker who is able to log in with an identical install, I see
> this, which looks like I would expect:

> jabber: Recv (ssl)(129): <stream:features><mechanisms xmlns='urn:ietf:params:xml:ns:xmpp-sasl'><mechanism>PLAIN</mechanism></mechanisms></stream:features>
> sasl: Mechs found: PLAIN 
> jabber: Sending (ssl) (DELETED at wisc.edu/Work): <auth xmlns='urn:ietf:params:xml:ns:xmpp-sasl' mechanism='PLAIN' xmlns:ga='http://www.google.com/talk/protocol/auth' ga:client-uses-full-bind-result='true'>password removed</auth>
> To my relatively clueless eyes, it looks like the remote server
> is saying, "Please use PLAIN."  When my coworker runs Pidgin,  it
> replies with the password.  When I run Pidgin, it replies with "I
> don't understand PLAIN, what other options are there?"

That's pretty much right. :)

> It was suggested that the package cyrus-sasl-plain might be
> missing, but RPM reports that cyrus-sasl-plain-2.1.22-5.el5_4.3
> is installed.  And even if it was, it doesn't explain why a
> co-worker using the same machine and same binary didn't encounter
> this problem.

Are you sure you don't have an architecture mismatch between the pidgin
rpm and the cyrus-sasl-plain package you have installed?

I'm by no means a RPM expert, but this does look like the sasl plugin is
missing.  Hopefully someone who's knowledgable about yum, rpm, and
RedHat's multiarch will jump in here. :)

Was your coworker actually using the same machine and same binary, or
was s/he using a system that has "an identical install"?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 897 bytes
Desc: OpenPGP digital signature
URL: <http://pidgin.im/pipermail/support/attachments/20100908/21af929f/attachment.sig>

More information about the Support mailing list