Problem of Pidgin 2.10.11 Compilation on OpenSUSE 13.2 x86_64

Shlomi Fish shlomif at
Mon Jan 12 08:22:34 EST 2015

Hi Mikhail,

please reply to all recipients (see the bottom line of my signature).

On Sun, 11 Jan 2015 02:40:13 +0200
Mikhail Kasimov <mikhail.kasimov at> wrote:

> Hello!
> Given: OpenSUSE 13.2 x86_64, XFCE 4.10. Pidgin version in repos is
> out-dated (2.10.10-5.4.1), so I tried to install it manual from sources
> downloaded from
> So, wget && tar && cd ./pidgin && ./configure. But ./configure fails with
> =====
> configure: error:
> You must have GLib 2.16.0 or newer development headers installed to build.
> If you have these installed already you may need to install pkg-config so
> I can find them.
> =====
> sudo zypper se -s pkg-config command shows that pkg-config 0.28-7.1.2
> x86_64 is installed.

pkg-config is and uses .pc
definition files to find what it needs. To install the relevant definition 
file, you need to install the appropriate "-devel" (= development) package. So
search for glib2-devel (and later other packages like that):


	Shlomi Fish

Shlomi Fish
List of Portability Libraries -

No one knows all of Perl. Not even Larry Wall. Except Chuck Norris, who knows
all of Perl 5, Perl 6, and can answer questions about the design of Perl 7.

Please reply to list if it's a mailing list post - .

More information about the Support mailing list