[Tracker] [Pidgin] #20: Rename core functions into the purple_* namespace.

Pidgin trac at pidgin.im
Mon Nov 6 23:58:30 EST 2006

#20: Rename core functions into the purple_* namespace.
  Reporter:  rlaager    |       Owner:  rlaager                    
      Type:  task       |      Status:  new                        
  Priority:  major      |   Milestone:  Go public with Pidgin 2.0.0
 Component:  libpurple  |     Version:  2.0                        
Resolution:             |    Keywords:                             
Comment (by rlaager):

 Ethan indicated he's against this change.

 My reasons are:

 1. This would help show a clean rename moving forward. No matter what
 level of settlement protection we have, I think we'll be safest moving
 forward if we just get rid of "gaim" entirely.

 2. It'd be less confusing in the future for plugin others and libpurple
 users to have the core (libpurple) stuff under a namespace of purple_* and
 the UI stuff under a namespace of pidgin_*. Separating the core and UI
 namespaces would also help make the library separation clear and obvious.

 3. If there's any chance this will happen ever, I want to do it now and be
 done with it. Renaming now will be the lowest amount of pain possible.

 If we want, we could create a compatibility layer like:

 #define gaim_foo purple_foo
 #define gaim_bar pidgin_bar

 It's not something I'd want to maintain, but it might help to just release
 it with the initial release of libpurple and Pidgin.

Ticket URL: <http://developer.pidgin.im/ticket/20#comment:5>
Pidgin <http://pidgin.im>

More information about the Tracker mailing list