[Pidgin] #3207: Request nickname for authorization request

Pidgin trac at pidgin.im
Fri May 14 19:33:32 EDT 2010


#3207: Request nickname for authorization request
------------------------------------+---------------------------------------
 Reporter:  collin                  |        Owner:  MarkDoliner 
     Type:  patch                   |       Status:  new         
Milestone:  Patches Needing Review  |    Component:  pidgin (gtk)
  Version:  2.0.2                   |   Resolution:              
 Keywords:                          |  
------------------------------------+---------------------------------------

Comment(by MarkDoliner):

 Ivan talked to me about this briefly over IM, and I was going to respond
 to him over IM, but then I figured it was better to leave a comment here,
 since this is more permanent and Collin might be interested, too.

  * We should avoid adding "--htfv" to most comments.  It's sometimes
 useful in longer comments that describe design decisions or implementation
 decisions, because it makes it easier for someone to ask the author of the
 code "why did you do it this way?"  But in smaller comments that just
 annotate the behavior of the code, the "--author" bit isn't really
 necessary.
  * If we don't think we'll use code again then we should just remove it
 instead of commenting it out.  Otherwise you wind up with lots of
 commented out code, which makes the source harder to read :-)
  * At the bottom of purple_icqalias() you can just g_free(info->reason).
 It should be NULL if info->auth_request is FALSE, and g_free(NULL) is
 harmless.
  * Ivan: I agree that coupling aim_icq_getalias with handling
 authorization requests makes the code more complicated and may not be the
 cleanest possible solution, but I'm totally ok with it.

-- 
Ticket URL: <http://developer.pidgin.im/ticket/3207#comment:15>
Pidgin <http://pidgin.im>
Pidgin


More information about the Tracker mailing list