[Pidgin] #17213: Pidgin ignores anchor in hyperlink

Pidgin trac at pidgin.im
Sat May 27 02:07:33 EDT 2017

#17213: Pidgin ignores anchor in hyperlink
 Reporter:  polytekpatrick  |      Owner:
     Type:  defect          |     Status:  new
Milestone:  2.12.1          |  Component:  pidgin (gtk)
  Version:  2.7.9           |   Keywords:  anchor link hyperlink firefox
 When I click on a web link in a pidgin chat or in the log viewer that
 contains an anchor (number sign followed by anchor name), pidgin opens the
 link in firefox without the anchor portion.

 The odd thing is that pidgin correctly underlines the entire link
 (including the anchor), and the hovertext is also correctly the entire
 link. Right-click > Copy Link Location also correctly copies the entire
 link. It's just clicking the link or using Right-click > Open Link that
 exhibits the problem.

 In my gnome preferences that define the default browser, I tried both the
 normal firefox option and manually setting a custom command of: firefox
 Neither worked, so it seems to be a bug in pidgin.

 I'm using Pidgin 2.7.9-27.el6 on CentOS 6 Linux, installed via yum. I
 don't have the option to try another version easily (offline environment).

Ticket URL: <https://developer.pidgin.im/ticket/17213>
Pidgin <https://pidgin.im>

More information about the Tracker mailing list