Finch (libpurple) & special characters

Timo Jyrinki timo.jyrinki at
Wed Nov 28 09:54:59 EST 2007

2007/11/28, Luke Schierer <lschiere at>:
> Using rxvt-unicode (also called urxvt), I hold control-shift and enter
> in the unicode hex code point, such as e4 for ä, and finch accepts it
> perfectly.  I do not know what is going on in your environment.  I do
> know that xterm basically has no unicode support unless run with the -u
> or -u8 (I forget which exactly) flag, and even then only limited
> support.

Yep (, but...). ä:s and ö:s work in every other application like
emacs, vim, irssi, shell etc. and have worked for several years. Also
xterm seems to display and manipulate UTF-8 characters correctly
nowadays at least in these mostly-ascii cases. The interesting thing
is that Finch works correctly outside X, from eg. tty1-6, and through
SSH connections in text console etc.  But not in X/GNOME. Since I've
not encountered any other text mode program having a similar problem
in recent years, I'd guess the problem is somehow, in Finch. Finch
does handle displaying of translations correctly, but the input does
not work in every case.

But you are correct, typing ä or ö in rxvt-unicode does work (both
directly or by using codes) - which is great news for my Finch usage.
It's just very weird how it does not work eg. in GNOME Terminal. I
also tried Konsole and XFCE Terminal which have been problem-free for
me before, but also those fail to work correctly with Finch.


More information about the Devel mailing list