new plugin

Phil Hannent phil at
Mon Dec 28 11:52:30 EST 2009


On 28/12/09 15:15, roby wrote:
> maybe something is broken by the new changes, i cannot test now because
> here at work we don't have a upnp router. To have more output you can
> execute
> pidgin -d
It reports:

calling GetExternalIPAddress
(16:38:45) g_log: Error copying value: value location for `gchararray' 
passed as NULL
Segmentation fault

> And i wrote some instructions in the wiki
> <>, be sure to
> have x11vnc and tightvnc installed.
on my system x11vnc nor tightvnc were not installed.

> If you feel like helping a lot you can obtain more info for the
> Segmentation fault in this way:
> gdb --args pidgin -d
> run
> (pidgin start, make it crash like usual)
> bt
> then there will be a lot of info.
I do not have the debug symbols available to me oddly, this is pidgin 
2.6.4 from the ubuntu PPA.

> You can disable upnp completely or enable the libpurple implementation
> (not working for me) in the configuration of the plugin.
Using the Pidgin upnp did not make it crash for me.  However I do not 
right now have someone to test against.

Also with that configuration the public IP is not being used:


>     This is all I get when I run it from the command line. Also good job
>     on the warnings, on my setup I have just 2 left:
>     client.c: In function ‘client_accept_connection_cb’:
>     client.c:60: warning: ignoring return value of ‘system’, declared
>     with attribute warn_unused_result
>     server.c: In function ‘upnp_discovery_cb’:
>     server.c:136: warning: ‘ip’ may be used uninitialized in this function
> ok, i'll take a look. Thank you for your testing, it's very difficult to
> test a social plugin alone :)
I fully understand, it always takes a number of iterations before the 
kinks are worked out.  I appreciate your hard work.

Phil Hannent

More information about the Devel mailing list