Compiling pidgin-otr for windows (cygwin OR cross-compile) errors

Sec secq.002 at
Thu Jul 9 22:11:40 EDT 2009


Has anyone successfully compiled this for windows ? 

I have tried cross compiling using linux and also tried to compile using windows and cygwin. 

With windows cygwin I get the following error when I try to "make -f Makefile.mingw"
make: i586-mingw32msvc-gcc: Command not found

On linux, I followed the instructions at
and get error with trying to find some header files. I am using debian lenny.

otr-plugin.c:32:20: error: gcrypt.h: No such file or directory
In file included from /usr/include/gtk-2.0/gdk/gdkx.h:36,
                 from /usr/include/pidgin/pidgin.h:33,
                 from otr-plugin.c:35:
/usr/include/X11/Xlib.h:60:19: error: X11/X.h: No such file or directory
/usr/include/X11/Xlib.h:63:28: error: X11/Xfuncproto.h: No such file or directory
/usr/include/X11/Xlib.h:64:25: error: X11/Xosdefs.h: No such file or directory

- I have libgcrypt11-dev installed and I can see /usr/include/gcrypt.h
- Its as though the directory /usr/include is not being seen. For example a header file of a devel package has #include  and Xlib.h is in /usr/include/X11/Xlib.h but it looks "make -f Makefile.mingw" makes it look for /X11/Xlib.h instead of /usr/include/X11/Xlib.h

Can anyone help fix the above two problems for cross-compiling in linux. OR how to get it compile in cygwin ? 

Many thanks,

Kill spammers and snoopers dead
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list