[OTR-dev] Compiling pidgin-otr for windows (cygwin OR cross-compile) errors

Ian Goldberg ian at cypherpunks.ca
Fri Jul 10 08:12:41 EDT 2009

On Fri, Jul 10, 2009 at 02:11:40AM -0000, Sec  wrote:
> Hi,
> Has anyone successfully compiled this for windows ? 
> I have tried cross compiling using linux and also tried to compile using windows and cygwin. 
> With windows cygwin I get the following error when I try to "make -f Makefile.mingw"
> make: i586-mingw32msvc-gcc: Command not found

Makefile.mingw is meant for cross compiling on Linux, with the mingw32
package installed.

> On linux, I followed the instructions at 
> http://ubuntuforums.org/showthread.php?t=558197
> and get error with trying to find some header files. I am using debian lenny.
> otr-plugin.c:32:20: error: gcrypt.h: No such file or directory

This sounds like you haven't installed a cross-compiled version of
libgcrypt.  The include files and libraries should live under

> In file included from /usr/include/gtk-2.0/gdk/gdkx.h:36,
>                  from /usr/include/pidgin/pidgin.h:33,
>                  from otr-plugin.c:35:
> /usr/include/X11/Xlib.h:60:19: error: X11/X.h: No such file or directory
> /usr/include/X11/Xlib.h:63:28: error: X11/Xfuncproto.h: No such file or directory
> /usr/include/X11/Xlib.h:64:25: error: X11/Xosdefs.h: No such file or directory

This seems wrong; the Windows cross-compile should not be using X, I'm
pretty sure (but that's in the pidgin stuff, which I don't know as well
as the OTR stuff).

   - Ian

More information about the Devel mailing list