Proposed changes for Pidgin 2.7.0

Paul Aurich paul at
Sun Jul 12 23:11:11 EDT 2009

And John Bailey spoke on 07/12/2009 08:04 PM, saying:
> Hey, everyone,
> It's come up recently in several venues of discussion including #pidgin and
> devel at that our policy of supporting old glib and GTK+ is
> ridiculous and limiting.


> In discussion in #pidgin, Paul, Kevin, and myself expressed a strong desire to
> kill support for old glib and GTK+.  Given what we are including in-tree to work
> on these ancient versions of libraries, I propose that for 2.7.0 we move to an
> absolute minimum of GTK+ 2.10.0 and Glib 2.12.0 (these were released in early
> July 2006).  Ideally, I would like to require even newer versions of both, but
> I'm compromising with the minimum version needed to kill all the extra libegg
> and GTK+ code that we're carrying.


> John

I also cast a vote in favor of the proposal.


More information about the Devel mailing list