Access is Denied

Jim Menkevich jim.menkevich at
Thu Aug 12 08:40:37 EDT 2010


On Windows 7, I selected to run Cygwin as Adminstrator and then I change the
permissions on the libpurple/win32 directory and all the files in the

chmod -Rf 777 libpurple/win32

drwxrwxrwx+ 1 testing None   4096 2010-08-11 15:48 win32

I'm still getting the same error.

So I tried to just execute the binary by itself and I still get  the same

$ windres
Access is denied.
g failed.

So I checked the permissions on that and I'm good there as well.

-rwxr-xr-x  1 testing None  678912 2009-10-23 19:11 windres.exe

I confirmed by executing '--help' on the binary and that worked without an

Does any of this info help?

I appreciate you taking the time to analyze this with me.


On Thu, Aug 12, 2010 at 12:24 AM, Yao Ko <yaoyao at> wrote:

> On Wed, Aug 11, 2010 at 7:48 PM, Jim Menkevich <jim.menkevich at>
> wrote:
> > All,
> > I've last compiled Pidgin on Windows with version 2.6.2 for an enterprise
> > project I was working on and I didn't have any issues.  I recently had
> > to resurrect the project again but with the latest source code.
> > There are new instructions for compiling on versions greater that 2.7.0,
> > which I followed to the T on both Windows 7 and Windows XP.
> > When I try to compile, everything is humming along until I get to
> libpurple.
> >
> > sed -e 's/@PURPLE_VERSION@/2.7.2/g' \
> >             win32/ > win32/libpurplerc.rc
> > windres -I../libpurple -i win32/libpurplerc.rc -o win32/libpurplerc.o
> > Access is denied.
> > C:\cygwin\home\testing\pidgin-devel\win32-dev\mingw\bin\windres.exe:
> > preprocess
> > ing failed.
> Do you have write permission on the win32 directory and/or the
> win32/libpurplerc.o file?  If you're on Cygwin, try "ls -l" and check
> for the file permission.
> Also, on Windows 7 with UAC, you may have to launch with administrator
> privileges.
> Yao
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Devel mailing list