Access is Denied

Daniel Atallah daniel.atallah at
Thu Aug 12 08:46:29 EDT 2010

On Thu, Aug 12, 2010 at 08:40, Jim Menkevich <jim.menkevich at> wrote:
> Yao,
> On Windows 7, I selected to run Cygwin as Adminstrator and then I change the
> permissions on the libpurple/win32 directory and all the files in the
> directory:
> chmod -Rf 777 libpurple/win32
> drwxrwxrwx+ 1 testing None   4096 2010-08-11 15:48 win32
> I'm still getting the same error.
> So I tried to just execute the binary by itself and I still get  the same
> message.
> $ windres
> Access is denied.
> C:\cygwin\home\testing\pidgin-dev\win32-dev\mingw\bin\windres.exe:
> preprocessin
> g failed.
> So I checked the permissions on that and I'm good there as well.
> -rwxr-xr-x  1 testing None  678912 2009-10-23 19:11 windres.exe
> I confirmed by executing '--help' on the binary and that worked without an
> issue.
> Does any of this info help?

You really shouldn't have to compile stuff as Adminstrator - I don't.

Check the permissions on $TMP and $TEMP.  It could be that windres is
writing stuff there temporarily.

Which version of windres do you have (`windres --version`)?


More information about the Devel mailing list