GObjectification - GSoC progress as of June 16, 2013
salinasv at gmail.com
Thu Jun 20 11:54:15 EDT 2013
On Thu, Jun 20, 2013 at 3:19 AM, Ankit Vani <a at nevitus.org> wrote:
> On 18 June 2013 21:33, Jorge Villaseñor <salinasv at gmail.com> wrote:
> > I would suggest a function name change from purple_sha1_hash_new() to
> > purple_hash_sha1_new() to keep the namespace/hierarchy more clear. The
> > for the cipher functions. The convention so far have been in the lines of
> > the following template -> purple_module_submodule_specific()
> That makes sense, however the convention used by me here is
> objecttype_function(). For example, PurpleAccount would have
> purple_account_new(). Similarly, PurpleSHA1Hash has purple_sha1_hash_new().
> It gives a clearer indication of the type that we are dealing with.
> The namespace/heirarchy is indicated by the name of the object's type.
I see, but I wonder, Why it is Called PurpleSHA1Hash instead of
It does make more sense to me to have Hash first because SHA1 is a type of
I don't know, it looks backwards to me.
> Subclasses are named as NamespaceDerivedBase, which is also the convention
> followed by glib, and by pidgin in the gobjectification branch.
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
Q: What is the most annoying thing on usenet and in e-mail?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Devel