GObjectification - GSoC progress as of June 16, 2013

Ankit Vani a at nevitus.org
Thu Jun 20 04:19:06 EDT 2013

On 18 June 2013 21:33, Jorge Villaseñor <salinasv at gmail.com> wrote:
> I would suggest a function name change from purple_sha1_hash_new() to
> purple_hash_sha1_new() to keep the namespace/hierarchy more clear. The same
> for the cipher functions. The convention so far have been in the lines of
> the following template -> purple_module_submodule_specific()

That makes sense, however the convention used by me here is
objecttype_function(). For example, PurpleAccount would have
purple_account_new(). Similarly, PurpleSHA1Hash has purple_sha1_hash_new().
It gives a clearer indication of the type that we are dealing with.
The namespace/heirarchy is indicated by the name of the object's type.

Subclasses are named as NamespaceDerivedBase, which is also the convention
followed by glib, and by pidgin in the gobjectification branch.


More information about the Devel mailing list