Compile error on AMD64.

Nuno Magalhães morceguinho at
Thu Nov 29 13:56:16 EST 2007


I'm using Debian Etch (4.0) on AMD64. The package repository doesn't
have pidgin yet, neither is this distro supported by pidgin
developers, so i tried to compile it. When i run ./configure, i get

checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for sed... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.

You can fing config.log here:

gcc is 4.1.2 and this is a fresh install. Am i missing packages here?

Fica bem, porta-te mal.
Be well, misbehave.

More information about the Support mailing list