Struggling with compilation of pidgin for windows

Kontostathis, April akontostathis at
Thu Oct 21 09:23:48 EDT 2010

See below (marked AK)

-----Original Message-----
From: daniel.atallah at [mailto:daniel.atallah at] On Behalf Of Daniel Atallah
Sent: Thursday, October 21, 2010 7:00 AM
To: Kontostathis, April
Cc: support at
Subject: Re: Struggling with compilation of pidgin for windows

On Wed, Oct 20, 2010 at 17:44, Kontostathis, April
<akontostathis at> wrote:
> I followed the instructions here:
> Which was non-trivial because the mingw links all take me to some high level
> directory that I needed to drill into to find what I thought was the right
> file to download/install/use.

Really?  I just checked the links and they all appear to be find for me.
When did you try this?  There was a period of time when the links were
broken due to sourceforge changes, but that was 4 months ago.
[AK] tried all day yesterday and this morning again, with firefox and IE browsers.  For example, I cannot find the file for GMP 4.2.4, I get a message that gmp-4.2.4-mingw32-dll.tar.gz is not found and I should select another file.  I have spent hours looking for this file and cannot find any file that appears to the be the right one.  When I set up the environment I used : libgmpxx-5.0.1-1-mingw32-dll-4.tar.lzma because that seemed closest to what I was looking for.

>  My current directory structure appears to be
> correct, but when I try to compile, I get:


> Further investigation revealed that just trying to compile something with
> gcc.exe (which is currently pointing to)
> $ which gcc.exe
> /cygdrive/c/devel/pidgin-devel/win32-dev/mingw/bin/gcc.exe

(It seems like something is missing from your message here.)
[AK] that is the point, there is no output at all, no messages, no object file, etc.

> Gets completely ignored (no errors, no compilation output either).
>  However, the libpurple.dll was created and if I reset my path to use the
> cygwin gcc (from /usr/bin) I can get it to compile, but it dies further down
> the road (probably when it tries to make a dll).

You don't want to use the cygwin gcc.  Was your compilation output
above produced with the cygwin gcc?
[AK] no

You will want to `make -f Makefile.mingw clean` in the root pidgin
directory to make sure that you get rid of any cygwin-dependent
objects - mixing stuff like that is only going to be a source of
[AK] I did this and I am still getting errors with the make -f Makefile.mingw install

> Any insight would be appreciated.

It's kind of hard to guess what might be wrong because there isn't any
particular error message in the output you posted.
My best guess is that you've missed one of the mingw pieces or
something like that.
[AK] I agree, but I can't seem to find all the pieces for mingw.  I also did an install of mingw using the installer and putting the results into the /devel/pidgin-devel/win32-dev/wingw directory, but that didn't help either.

What does `gcc -v` output?

[AK] $ gcc -v
Using built-in specs.
Target: mingw32
Configured with: ../gcc-4.4.0/configure --enable-languages=c,ada,c++,fortran,jav
a,objc,obj-c++ --disable-sjlj-exceptions --enable-shared --enable-libgcj --enabl
e-libgomp --with-dwarf2 --disable-win32-registry --enable-libstdcxx-debug --enab
le-version-specific-runtime-libs --prefix=/mingw --with-gmp=/mingw/src/gmp/root
--with-mpfr=/mingw/src/mpfr/root --build=mingw32
Thread model: win32
gcc version 4.4.0 (GCC)
--> end [AK]

Have you tried manually compiling a test C source file directly with gcc?

[AK] yes, nothing happens.  No compiler errors, no output

[AK> Any other ideas?


More information about the Support mailing list