Struggling with compilation of pidgin for windows

Daniel Atallah datallah at
Thu Oct 21 11:20:00 EDT 2010

On Thu, Oct 21, 2010 at 09:23, Kontostathis, April
<akontostathis at> wrote:
> See below (marked AK)
> -----Original Message-----
> From: daniel.atallah at [mailto:daniel.atallah at] On Behalf Of Daniel Atallah
> Sent: Thursday, October 21, 2010 7:00 AM
> To: Kontostathis, April
> Cc: support at
> Subject: Re: Struggling with compilation of pidgin for windows
> On Wed, Oct 20, 2010 at 17:44, Kontostathis, April
> <akontostathis at> wrote:
>> I followed the instructions here:
>> Which was non-trivial because the mingw links all take me to some high level
>> directory that I needed to drill into to find what I thought was the right
>> file to download/install/use.
> Really?  I just checked the links and they all appear to be find for me.
> When did you try this?  There was a period of time when the links were
> broken due to sourceforge changes, but that was 4 months ago.
> [AK] tried all day yesterday and this morning again, with firefox and IE browsers.  For example, I cannot find the file for GMP 4.2.4, I get a message that gmp-4.2.4-mingw32-dll.tar.gz is not found and I should select another file.  I have spent hours looking for this file and cannot find any file that appears to the be the right one.  When I set up the environment I used : libgmpxx-5.0.1-1-mingw32-dll-4.tar.lzma because that seemed closest to what I was looking for.

Ah, That is probably the cause of the problem.  It does look like that
link is broken, I didn't check all the links this morning, just the
first few.

Until I get a chance to update the wiki page, you might have better
luck using the "full" mingw gcc package available here:

> It's kind of hard to guess what might be wrong because there isn't any
> particular error message in the output you posted.
> My best guess is that you've missed one of the mingw pieces or
> something like that.
> [AK] I agree, but I can't seem to find all the pieces for mingw.  I also did an install of mingw using the installer and putting the results into the /devel/pidgin-devel/win32-dev/wingw directory, but that didn't help either.

> Have you tried manually compiling a test C source file directly with gcc?
> [AK] yes, nothing happens.  No compiler errors, no output
> [AK> Any other ideas?

You'll need to get the mingw compiler working before anything else is
going to work, hopefully the above "full" gcc archive does the trick.
You'll want to get rid of any traces of the previous "mixed" version
that you had.


More information about the Support mailing list