Jabberd2: nss: Handshake failed

sashko at my-server.km.ua sashko at my-server.km.ua
Mon Apr 11 04:27:47 EDT 2016

Yes, we tried to use this plug-in, but it did no good. We turned it on, but did not touch the settings.

log (windows xp, pidgin 2.10.12)
(11:22:48) account: Connecting to account sashko at myims.pp.ua/home.
(11:22:48) connection: Connecting. gc = 015B9AC8
(11:22:48) dnsquery: Performing DNS lookup for myims.pp.ua
(11:22:48) dnsquery: IP resolved for myims.pp.ua
(11:22:48) proxy: Attempting connection to
(11:22:48) proxy: Connecting to myims.pp.ua:5222 with no proxy
(11:22:48) proxy: Connection in progress
(11:22:48) proxy: Connecting to myims.pp.ua:5222.
(11:22:48) proxy: Connected to myims.pp.ua:5222.
(11:22:49) nss: Handshake failed  (-12263)
(11:22:49) connection: Connection error on 015B9AC8 (reason: 5 description: SSL-рукопожатие не удалось)
(11:22:49) account: Disconnecting account sashko at myims.pp.ua/home (0256D630)
(11:22:49) connection: Disconnecting connection 015B9AC8
(11:22:49) connection: Destroying connection 015B9AC8

11.04.2016, 11:07, "Eion Robb" <eion at robbmob.com>:
> Hi there,
> Just wondering if you've tried using the "NSS Preferences" plugin in Pidgin to adjust what methods of TLS/SSL encryption you're using to connect to your server?
> If you have and you're still having trouble, are you able to pastebin a full debug log (from the buddy list, Help->Debug Window), as you connect to the server and get the SSL handshake error?
> Cheers,
> Eion
> On 11 April 2016 at 19:02, <sashko at my-server.km.ua> wrote:
>> Dear support team, good afternoon. I'm having serious problems with the product. The fact that we are trying to make a stand-alone Jabber server. As a customer of our employees are already using Pidgin. We believe that this is the best client IM. But, unfortunately, there was an error SSL.
>> In Jabberd2 (2.2.8) is used as a server as a client - 2.6.6. There is a SSL connection error (nss: Handshake failed (-5938)). Unsecured connection is working properly. We tried to run the latest client and server assembly 2.10.11 (nss and gnutls). For jabberd2 - openssl 1.0.1, but we got a similar error. Also, apply the patch (https://github.com/jabberd2/jabberd2/commit/ad9ead7816e23f48d9b46905bcbe17b7b4b6a910). It also does not solve the problem.
>> Please help solve the problem.
>> Best regards, Alexander
>> _______________________________________________
>> Support at pidgin.im mailing list
>> Want to unsubscribe?  Use this link:
>> https://pidgin.im/cgi-bin/mailman/listinfo/support

More information about the Support mailing list