Jabberd2: nss: Handshake failed

Eion Robb eion at robbmob.com
Mon Apr 11 04:06:41 EDT 2016

Hi there,

Just wondering if you've tried using the "NSS Preferences" plugin in Pidgin
to adjust what methods of TLS/SSL encryption you're using to connect to
your server?

If you have and you're still having trouble, are you able to pastebin a
full debug log (from the buddy list, Help->Debug Window), as you connect to
the server and get the SSL handshake error?


On 11 April 2016 at 19:02, <sashko at my-server.km.ua> wrote:

> Dear support team, good afternoon. I'm having serious problems with the
> product. The fact that we are trying to make a stand-alone Jabber server.
> As a customer of our employees are already using Pidgin. We believe that
> this is the best client IM. But, unfortunately, there was an error SSL.
> In Jabberd2 (2.2.8) is used as a server as a client - 2.6.6. There is a
> SSL connection error (nss: Handshake failed (-5938)). Unsecured connection
> is working properly. We tried to run the latest client and server assembly
> 2.10.11 (nss and gnutls). For jabberd2 - openssl 1.0.1, but we got a
> similar error. Also, apply the patch (
> https://github.com/jabberd2/jabberd2/commit/ad9ead7816e23f48d9b46905bcbe17b7b4b6a910).
> It also does not solve the problem.
> Please help solve the problem.
> Best regards, Alexander
> _______________________________________________
> Support at pidgin.im mailing list
> Want to unsubscribe?  Use this link:
> https://pidgin.im/cgi-bin/mailman/listinfo/support
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://pidgin.im/pipermail/support/attachments/20160411/3cbefa41/attachment.html>

More information about the Support mailing list