Problem building Pidgin.

DAVID MAY maydavidr at
Wed May 5 09:11:00 EDT 2021


Sorry if this is the wrong forum, but this is the first time I have
worked with Pidgin.

I am experiencing an error when I attempt to build Pidgin 3.0 on Windows
with MSYS2.   Actually, I am only interested in working with libpurple
but it does not seem to be possible to build libpurple as a standalone

I cloned the Pidgin 3.0 Mercurial repository. However for
Pidgin 3.0 fails with an error message which states that Mercurial is
not installed.  This cannot be correct: I can clone the talkatu
Mercurial repository using MSYS2 Mercurial; Meson builds talkatu as a
standalone project; the build products talkatu pass all the tests and
the demo program works.

The full Pidgin 3.0 output I see is this:

$ meson build
The Meson build system
Version: 0.58.0
Source dir: C:/msys64/home/david/projects/pidgin
Build dir: C:/msys64/home/david/projects/pidgin/build
Build type: native build
Project name: pidgin
Project version: 3.0.0-devel
C compiler for the host machine: cc (gcc 10.2.0 "cc (Rev11, Built by
MSYS2 project) 10.2.0")
C linker for the host machine: cc ld.bfd 2.36.1
Host machine cpu family: x86_64
Host machine cpu: x86_64
Program gettext found: YES (C:\msys64\mingw64\bin/gettext.EXE)
Program C:/msys64/mingw64/bin/meson found: YES
Program found: YES (C:/msys64/mingw64/bin/python.exe
Program xgettext found: YES (C:\msys64\mingw64\bin/xgettext.EXE)
Library ws2_32 found: YES
Library dnsapi found: YES
Has header "sys/wait.h" : NO
Has header "unistd.h" : YES
Has header "fcntl.h" : YES
Has header "stdint.h" : YES
Checking for size of "time_t" : 8
Header <ws2tcpip.h> has symbol "socklen_t" : YES
Checking whether type "struct sockaddr" has member "sa_len" : NO
Library m found: YES
Found pkg-config: C:\msys64\mingw64\bin/pkg-config.EXE (0.29.2)
Run-time dependency glib-2.0 found: YES 2.68.1
Run-time dependency gio-2.0 found: YES 2.68.1
Run-time dependency gobject-2.0 found: YES 2.68.1
Run-time dependency gthread-2.0 found: YES 2.68.1
Run-time dependency gobject-introspection-1.0 found: YES 1.66.1
Run-time dependency nice found: YES 0.1.18
Run-time dependency gtk+-3.0 found: YES 3.24.29
Found CMake: C:\msys64\mingw64\bin/cmake.EXE (3.20.2)
Run-time dependency talkatu found: NO (tried pkgconfig and cmake) ERROR: Mercurial program not found.

David May

More information about the Support mailing list