Problem building pidgin (talkatu)

Konstantin Kharlamov hi-angel at
Sun Apr 3 14:46:36 EDT 2022

Regarding the error: it is trying to fetch talkatu repo, but the repo was
deleted, which is why you're getting a 404. This really should be reported to
the developers. It is trivial to fix: just replace (I presume in,
but am not sure, you might want to grep for the string over the sources) the


that's the new URL of the repo.

With that said: I am not sure you're really doing the correct thing. You see,
you're trying to build a 3.0 version of Pidgin, that's the development version,
which AFAIK has major changes to plugin API. Latest stable Pidgin release is

Is there any particular reason you're trying to build Pidgin from sources? It is
usually in repositories of all distros, so there should be no reason in doing
that other than wanting to do the Pidgin development (not even a plugin
development, that one doesn't require building Pidgin from sources).

On Sun, 2022-04-03 at 14:19 -0400, Ralph Hyre (edu edition) wrote:
> I've not seen 400 errors before, but it seems that the attempt to build
> talkatu - as part of a pidgin source build, is causing one.
> ralphw7 at asimov:~/src/pidgin/Pidgin-master$ meson build
> The Meson build system
> Version: 0.53.2
> Source dir: /home/ralphw7/src/pidgin/Pidgin-master
> Build dir: /home/ralphw7/src/pidgin/Pidgin-master/build
> Build type: native build
> Project name: pidgin
> Project version: 3.0.0-devel
> C compiler for the host machine: cc (gcc 9.4.0 "cc (Ubuntu
> 9.4.0-1ubuntu1~20.04.1) 9.4.0")
> C linker for the host machine: cc ld.bfd 2.34
> Host machine cpu family: x86_64
> Host machine cpu: x86_64
> Program sed found: YES (/usr/bin/sed)
> Program found: YES
> (/home/ralphw7/src/pidgin/Pidgin-master/
> Has header "sys/wait.h" : YES
> Has header "fcntl.h" : YES
> Has header "unistd.h" : YES
> Has header "stdint.h" : YES
> Checking for size of "time_t" : 8
> Checking for function "inet_aton" : YES
> Checking for function "gethostent" : YES
> Checking for function "socket" : YES
> Checking for function "getaddrinfo" : YES
> Checking for function "inet_ntop" : YES
> Checking for function "getifaddrs" : YES
> Header <sys/socket.h> has symbol "socklen_t" : YES
> Checking whether type "struct sockaddr" has member "sa_len" : NO
> Header <netinet/in.h> has symbol "IPV6_V6ONLY" : YES
> Library m found: YES
> Found pkg-config: /usr/bin/pkg-config (0.29.1)
> Run-time dependency glib-2.0 found: YES 2.64.6
> Run-time dependency gio-2.0 found: YES 2.64.6
> Run-time dependency gobject-2.0 found: YES 2.64.6
> Run-time dependency gthread-2.0 found: YES 2.64.6
> Found CMake: /usr/bin/cmake (3.16.3)
> Run-time dependency gobject-introspection-1.0 found: NO (tried pkgconfig
> and cmake)
> Run-time dependency gtk+-3.0 found: YES 3.24.20
> Run-time dependency talkatu found: NO (tried pkgconfig and cmake)
> abort: HTTP Error 404: Not Found
> Traceback (most recent call last):
>   File "/usr/lib/python3/dist-packages/mesonbuild/", line 129,
> in run
>     return options.run_func(options)
>   File "/usr/lib/python3/dist-packages/mesonbuild/", line 245, in
> run
>     app.generate()
>   ... more python stack trace
>   File "/usr/lib/python3.8/", line 364, in check_call
>     raise CalledProcessError(retcode, cmd)
> subprocess.CalledProcessError: Command '['/usr/bin/hg', 'clone', '
>', 'talkatu']' returned non-zero exit
> status 255.
> What's the run-time dependency trying to be resolved here?
> All I had to do so far, was install gtk3 and the meson build environment.
> I'm on ubuntu 20.04:lsb_release -a
> No LSB modules are available.
> Distributor ID: Ubuntu
> Description: Ubuntu 20.04.4 LTS
> Release: 20.04
> Codename: focal
> _______________________________________________
> Support at mailing list
> Want to unsubscribe?  Use this link:

More information about the Support mailing list