no protocols in nullclient (MSVC)

David Byron dbyron at
Fri May 25 19:25:13 EDT 2007

On Friday, May 25, 2007 @ 11:15a, Daniel Atallah wrote:

> On 5/25/07, David Byron <dbyron at> wrote:
> > If anyone has info on how to get debug info so that MSVC
> > can use it as well as what's actually going on here with
> > the protocols, it would be a big help.
> I don't believe it is possible to do that without building
> libpurple with msvc.

I was afraid of that.  I'll ignore this for now and hope I never really need
to do it.  Heh.

> I think the problem is probably that it isn't finding any
> of the protocols.
> Do you have the various protocol dll in
> /path/to/libpurple.dll/plugins?

I didn't, but I do now.  I was pointing the linker at the libpurple.lib I'd
created in the libpurple directory.  When I point the linker at the
win32-install-dir, I get a bunch more output.  Still the same problem
(purple_plugins_get_protocols returns NULL) but more output.

I went ahead and changed /dev/null in defines.h to a directory that actually
exists, but I still get a NULL pointer from purple_plugins_get_protocols.
Changing CUSTOM_PLUGIN_PATH from the empty string to my
win32-install-dir/plugins directory, I get the protocols I expect.  Do other
people need to change defines.h to get protocols to appear?

I entered my yahoo ID in and got some output I didn't expect but I have some
more homework to do to figure out what's supposed to be happening here.

connection: Connecting. gc = 00A539D8
dnsquery: Performing DNS lookup for
prefs: /purple/savedstatus/default changed, scheduling save.
dnsquery: IP resolved for
proxy: Attempting connection to
proxy: Connecting to with no proxy
proxy: Connection in progress
proxy: Connected to
yahoo: 93 bytes to read, rxlen is 113
yahoo: Yahoo Service: 0x57 Status: 1
yahoo: yahoo status: 0
yahoo: 34 bytes to read, rxlen is 54
yahoo: Yahoo Service: 0x54 Status: -1
yahoo: Error in YMSG stream, got something not a YMSG packet!account:
ing account 00A52658
connection: Disconnecting connection 00A539D8
connection: Destroying connection 00A539D8

Thanks again for your help.


More information about the Devel mailing list